# Table of Contents

AgiSoft StereoScan Overview ........................................................................................................ iv
1. Getting Started ............................................................................................................................... 1
   Loading Images ............................................................................................................................ 1
   Loading images as individual frames ......................................................................................... 1
   Loading images as a single stereo image .................................................................................... 1
   Building 3D Model ....................................................................................................................... 1
   Editing 3D Model .......................................................................................................................... 2
   Decimation tool ............................................................................................................................. 2
   Connected component filtering ................................................................................................. 3
   Manual face removal .................................................................................................................... 3
   Editing mesh using an external program ..................................................................................... 3
   Saving 3D Model .......................................................................................................................... 4
   Aligning Stereoscopic Images ....................................................................................................... 4
   Saving Stereoscopic Images .......................................................................................................... 5
2. Reference ......................................................................................................................................... 6
   Operation Modes .......................................................................................................................... 6
   Case 1: Both focal length and "crop factor" are present in the EXIF meta data ......................... 6
   Case 2: Only the focal length value is present in the EXIF meta data ..................................... 6
   Case 3: There is no EXIF information at all, or the focal length value is missing .................... 7
   StereoScan Project Files ............................................................................................................. 7
   3D View Navigation ..................................................................................................................... 7
   Toolbar Buttons ............................................................................................................................ 8
   Menu Commands .......................................................................................................................... 10
AgiSoft StereoScan Overview

StereoScan is a tool you can use to create textured 3D models from stereo image pairs. The images can be taken from any positions, providing that an object to be reconstructed is visible on both frames. The stereo pairs can be loaded as individual image files, side-by-side JPS images or JPEG Multi-Picture Format (MPO) images, like those captured by FujiFilm Real 3D W1 stereo camera.

You can also use StereoScan to align and save stereo images in common anaglyph or side-by-side stereo format.

Both stereo image alignment and 3D model reconstruction is fully automated and typically takes less than 1 minute for a single stereo pair on a modern PC.

Reconstructed 3D models can be saved in one of the following formats: Wavefront OBJ, 3DS Max, PLY, VRML, COLLADA, Universal 3D, PDF.
Chapter 1. Getting Started

Loading Images

The following stereo image formats are supported by StereoScan:

• Left/Right frames saved in separate JPEG files
• JPEG-based stereoscopic images
• JPEG Multi-Picture Format files

Loading images as individual frames

To load a stereo pair as individual frames

1. On the File menu, click Open Left/Right Images... or use toolbar button.
2. In the Open Left Image dialog box, browse to the file, containing the left image of a stereo pair, and click Open.
3. In the Open Right Image dialog box, browse to the file, containing the right image of a stereo pair, and click Open.

Loading images as a single stereo image

To load a stereo pair as a single stereo image

1. On the File menu, click Open Stereo Image... or use toolbar button.
2. In the Open dialog box, select the desired image format in the "Files of type" combo box. Browse to the file, containing the stereo pair, and click Open.

Note

• Use the original files from your camera whenever possible. EXIF information in JPEG images helps to obtain more accurate calibration results.

• If you loaded left/right images in the wrong order, use toolbar button to swap the frames.

• If the photos were captured in the vertical orientation, and your camera saves this information in EXIF metadata, you will be asked to auto rotate the images.

• To display EXIF information for the loaded stereo pair use File Info... command from the View menu.

Building 3D Model

To build a 3D model

1. Load the stereo pair if you haven't done it already. See more details in the Loading Images section.
2. Switch to the 3D view using toolbar button. You will be prompted to build a 3D model if it was not built yet. Alternatively, use Build 3D Model... command from the Tools menu.

3. In the Build 3D Model dialog box, select the desired model quality, and click OK.

4. The progress dialog box will appear displaying the current processing status. To cancel processing click the Cancel button.

**Note**

- 3D model reconstruction is a computationally intensive operation, and can take up to 1 minute for a single stereo pair on a modern PC.

- By default, the reconstructed model is automatically decimated to the acceptable face count and filtered. You can adjust parameters or disable automatic mesh postprocessing in the Preferences dialog box.

- Distortion correction can be enabled or disabled in the Preferences dialog using Correct distortions check box.

## Editing 3D Model

The following mesh editing tools are available in StereoScan:

- **Decimation tool**
- **Connected component filtering**
- **Manual face removal**
- **Editing mesh using an external program**

### Decimation tool

Decimation is a tool to decrease the geometric resolution of the model by replacing high resolution mesh with a lower resolution one, which is still capable of representing the object geometry with high accuracy.

StereoScan tends to produce 3D models with excessive geometry resolution, so mesh decimation is usually a desirable step after geometry computation.

#### To decimate 3D model

1. Switch to 3D view using toolbar button. You will be prompted to build a 3D model if you haven't done it already.

2. On the Mesh menu, click Decimate Mesh....

3. In the Decimate Mesh dialog box specify the target number of faces, which should remain in the final model. Click on the OK button to start decimation.

4. The progress dialog box will appear displaying the current processing status. To cancel processing click on the Cancel button.
Connected component filtering

Connected component filtering helps to remove small isolated mesh fragments, which are usually reconstructed incorrectly or are unneded.

To remove small isolated mesh fragments

1. Switch to 3D view using toolbar button. You will be prompted to build a 3D model if you haven't done it already.
2. On the Edit menu, click Select Components....
3. In the Select Components dialog box specify an amount of isolated components to be selected using the slider. You can observe how the selection changes while dragging the slider. Click OK button to finalize the selection.
4. On the Edit menu, click Delete Faces to remove the selected components.

Manual face removal

To manually remove part of the faces

1. Switch to 3D view using toolbar button. You will be prompted to build a 3D model if you haven't done it already.
2. Select rectangle or circle selection tool using or toolbar buttons.
3. Select the desired faces using your mouse. Use Ctrl to add new faces to the current selection.
4. To delete selected faces click on the toolbar button. To crop selection click on the toolbar button.

To grow or shrink current selection

1. To grow current selection press PageUp button in selection mode. To grow selection by even a larger amount, press PageUp while holding Shift key pressed.
2. To shrink current selection press PageDown button in selection mode. To shrink selection by even a larger amount, press PageDown while holding Shift key pressed.

Editing mesh using an external program

To export mesh for editing in the external program

1. On the Mesh menu, click Export and then Mesh....
2. In the Save As dialog box, select the desired mesh format in the "Save as type" combo box (Wavefront OBJ or Stanford PLY). Select the file name to be used for the model and click Save.

To import edited mesh

1. On the Mesh menu, click Import and then Mesh....
2. In the Open dialog box, select the mesh format of the edited model in the "Files of type" combo box (Wavefront OBJ or Stanford PLY). Browse to the file, containing the edited model, and click Open.

**Note**

- To revert all changes done to the mesh, select Reset command from the Mesh menu. Undo command for individual operations is not supported yet.

## Saving 3D Model

StereoScan supports saving models in one of the following 3D model formats:

- Wavefront OBJ (.obj)
- 3DS Max (.3ds)
- VRML (.wrl)
- Stanford PLY (.ply)
- COLLADA (.dae)
- Universal 3D (.u3d)
- Adobe PDF (.pdf)

**To save 3D model**

1. On the File menu, click Save 3D Model....
2. In the Save As dialog box, select the desired mesh format in the "Save as type" combo box. Select the file name to be used for the model and click Save.
3. If the selected mesh format requires saving texture in a separate file, you will also be prompted to select the file name for the texture.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click on the Cancel button.

**Note**

- Saving 3D model with a high face count (more than 100,000 faces) can take a long time. It is recommended to decimate the model to an appropriate face count before saving. Please read Editing 3D Model section for more details.

## Aligning Stereoscopic Images

**To align a stereo pair**

1. Load the stereo pair if you haven't done it already. See more details in Loading Images section.
2. Switch to the Side-by-side view or Anaglyph view. You will be prompted to align a stereo pair if it was not aligned yet. Alternatively, use Align Stereo Pair command from the Tools menu.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click the Cancel button.

4. Adjust parallax setting using Increase Parallax or Decrease Parallax toolbar buttons. You can also adjust parallax setting with your mouse while pressing the right mouse button.

**Note**

- Distortion correction can be enabled or disabled in the Preferences dialog using Distortion correction check box.

- In **Side-by-side** view the stereo pair is displayed in parallel eye setting.

- In **Anaglyph** view the stereo pair is displayed in red and cyan, with red being used for the left channel.

## Saving Stereoscopic Images

Aligned stereo pairs can be saved in one of the following formats:

- JPEG-based stereoscopic images
- Anaglyph images

**To save aligned stereo pair**

1. On the File menu, click Save Stereo Image....

2. In the Save As dialog box, select the desired stereo image format in the "Save as type" combo box. Select the file name to be used for the image and click Save.
Chapter 2. Reference

Operation Modes

StereoScan uses a slightly different processing algorithms, depending on the EXIF meta data found in the source images.

The following 3 cases are handled by the software:

1. Both camera focal length and "crop factor" can be estimated based on the EXIF information.
2. Only the focal length is recorded in the EXIF metadata.
3. There is no EXIF information at all, or the focal length value is missing.

Case 1: Both focal length and "crop factor" are present in the EXIF meta data.

This is the case when the best 3D reconstruction results can be expected.

The software assumes that the images are loaded directly from the camera without any cropping or other geometric transformations. The focal length value and camera "crop factor" provide a good initialization point for stereo alignment algorithm.

The following EXIF tags should be present in this case:

• FocalLength
• FocalLengthIn35mmFilm

Common combination for Nikon, Casio, etc.

or

• FocalLength
• FocalPlaneXResolution
• FocalPlaneYResolution

Common combination for Canon, Fujifilm, etc.

Not all digital cameras write enough information in the EXIF meta data. For example, we have observed that photos from the Sony Cyber-shot cameras doesn't contain 35mm focal length equivalent value or focal plane resolution data.

Case 2: Only the focal length value is present in the EXIF meta data.

In this case it is assumed that the images are also loaded directly from the digital camera, but the cameras firmware doesn't save 35mm focal length equivalent value or focal plane resolution data.

The "crop factor" in this case is estimated directly from the image data, based on the assumption that the principal point is exactly in the image center. There are some critical configurations of the camera setup
when this estimation is not possible. The depth of the scene should be also big enough so that the crop factor can be estimated reliably.

In practice, the cases when this estimation fails or gives unreliable results are relatively common, so it is recommended to use digital cameras which record 35mm focal length equivalent or focal plane resolution data.

**Case 3: There is no EXIF information at all, or the focal length value is missing.**

In this case it is assumed that the images were cropped or somehow transformed. The principal point could be relatively far from the image center and focal length estimation is not possible. The geometry in this case can be reconstructed only up to an arbitrary projective transformation of 3D space, so the angles can be reconstructed incorrectly.

**StereoScan Project Files**

StereoScan uses an internal project file format (with .ssz extension) to save the current project for future use.

StereoScan ssz project file format supercedes the older ssc file format and is designed to be more extensible. The project files stored in outdated ssc file format can be still opened using Open SSC... command from the File menu. Saving projects in the old ssc format is no longer supported.

The following information is saved inside the StereoScan project files:

- Original left and right frames, which were loaded by the user.
- Stereo pair alignment data, if any.
- Reconstructed 3D model including any changes made by the user, if any.

**Note**

- The parallax shift value is not recorded in the StereoScan project files. The value of parallax shift will be reset to zero when loading the saved StereoScan project.
- The images are stored internally with JPEG compression, without any recompression when possible.

**3D View Navigation**

StereoScan supports the following tools for navigation in 3D view mode:

- Rotation Tool
- Pan Tool
- Zooming Tool

All navigation tools are accessible in the Navigation mode only. To enter Navigation mode click the Navigation toolbar button.
Different navigation tools are selected depending on the state of the following keys:

**Rotation Tool**
Default

**Pan Tool**
Ctrl key pressed

**Zooming Tool**
Shift key pressed

Note
- The zooming into the model can be also controlled by the mouse wheel.

## Toolbar Buttons

### General commands

- ![Open Stereo Image](image)
  **Open Stereo Image**
  Loads a stereo image in JPEG-stereoscopic or Multi-Picture format.

- ![Open Left/Right Images](image)
  **Open Left/Right Images**
  Loads Left/Right frames stored in separate JPEG files.

- ![Open](image)
  **Open**
  Opens a StereoScan project file.

- ![Save](image)
  **Save**
  Saves a StereoScan project file.

### StereoScan view modes

- ![Left frame view](image)
  **Left frame view**
  Opens the left stereo frame.

- ![Right frame view](image)
  **Right frame view**
  Opens the right stereo frame.

- ![Swap frames](image)
  **Swap frames**
  Swaps left and right stereo images.

- ![3D view](image)
  **3D view**
  Opens 3D model view.

- ![Depth view](image)
  **Depth view**
  Opens calculated raw depth map for the left frame.


- **Side-by-side view**
  Shows aligned stereo pair in side-by-side view.

- **Anaglyph view**
  Shows aligned stereo pair in anaglyph mode.

**Mesh editing operations (3D view only)**

- **Navigation**
  Switches to model navigation mode.

- **Rectangle Selection**
  Enables rectangle face selection tool.

- **Circle Selection**
  Enables circle face selection tool.

- **Crop**
  Crops selected faces.

- **Delete**
  Removes selected faces from the mesh.

- **Undo**
  Undo the last mesh editing operation.

- **Redo**
  Redo the previously undone mesh editing operation.

**3D view settings (3D view only)**

- **Textured**
  Displays 3D model in textured mode.

- **Shaded**
  Displays 3D model in shaded mode.

- **Solid**
  Displays 3D model in solid mode.

- **Wireframe**
  Displays 3D model in wireframe mode.

- **Reset View**
  Resets view to the initial viewing position.
Stereoscopic image operations (Side-by-side and Anaglyph view only)

Decrease Parallax
Decreases stereo parallax shift.

Increase Parallax
Increases stereo parallax shift.

Menu Commands

File Menu

Open...
Opens StereoScan project file.

Save
Saves StereoScan project file.

Save As...
Saves StereoScan project file with a new name.

Open SSC...
Opens StereoScan project file stored in old SSC format.

Open Stereo Image...
Loads a stereo image in JPEG-stereoscopic or Multi-Picture format.

Open Left/Right Images...
Loads Left/Right frames stored in separate JPEG files.

Save 3D Model...
Saves 3D model.

Save Stereo Image...
Saves aligned stereoscopic image.

Save Left/Right Images...
Saves original left/right images in JPEG format.

Save Depth Maps...
Saves reconstructed left/right depth maps as grayscale images.

Exit
Quits the application. Prompts to save active project.
Edit Menu

Undo
Undo the last mesh editing operation.

Redo
Redo the previously undone mesh editing operation.

Delete Faces
Removes selected faces from the mesh.

Crop Faces
Crops selected faces.

Grow Selection
Grows current selection.

Shrink Selection
Shrinks current selection.

Select Components...
Selects small mesh components.

View Menu

Textured
Displays 3D model in textured mode.

Shaded
Displays 3D model in shaded mode.

Solid
Displays 3D model in solid mode.

Wireframe
Displays 3D model in wireframe mode.

Show Ruler
Shows or hides ruler.

Show Trackball
Shows or hides trackball.

Show Info
Shows or hides mesh information on-screen display.
**File Info...**
Displays EXIF information of the opened stereo pair.

**Toolbars and Docking Windows->Standard**
Shows or hides toolbar.

**Toolbars and Docking Windows->Output**
Shows or hides pane with debug information.

**Status Bar**
Shows or hides status bar.

**Tools Menu**

**Build 3D Model...**
Generates 3D model.

**Align Stereo Pair**
Aligns stereo pair.

**Preferences...**
Shows preferences dialog box.

**Mesh Menu**

**Reset Mesh**
Resets all changes made to the model.

**Decimate Mesh...**
Decimates mesh to the target face count.

**Import->Mesh...**
Imports edited mesh from the external program.

**Import->Texture...**
Imports edited texture from the external program.

**Export->Mesh...**
Exports mesh for editing in the external program.

**Export->Texture...**
Exports texture for editing in the external program.

**Display Mesh Statistics...**
Collects and displays mesh statistics.
Help Menu

Help Topics
Displays help contents.

Check for Updates...
Checks if StereoScan update is available for download.

About StereoScan...
Displays program information, version number and copyright.